Unable to activate a Jeppesen charts subscription in the Garmin Pilot app
Created Date:
Feb 2025
Article ID:
000002988
Version:
3
Environment:
iOS
Document Type(s):
--
Related Products: --
PROBLEM:
When activating a Jeppesen charts subscription in Garmin Pilot, a subscription does not show up under "Activate a License", or it states "There are no applicable subscriptions on this account".

CAUSE:
The account does not have an active charts subscription that is supported in Garmin Pilot, or there are no more seats (site keys/installs) available for the subscription.
RESOLUTION:
Make sure you're logging in under the correct account that has the charts subscription. Log into https://shop.jeppesen.com/, click the Profile icon
, then My Subscriptions to check the status of your charts subscription.
When activating a Jeppesen charts subscription in Garmin Pilot, a subscription does not show up under "Activate a License", or it states "There are no applicable subscriptions on this account".
CAUSE:
The account does not have an active charts subscription that is supported in Garmin Pilot, or there are no more seats (site keys/installs) available for the subscription.
RESOLUTION:
Make sure you're logging in under the correct account that has the charts subscription. Log into https://shop.jeppesen.com/, click the Profile icon