"JeppView.exe - Bad Image" error appears after opening JeppView for Windows
Created Date:
Mar 2025
Article ID:
000003095
Version:
2
Environment:
Windows
Document Type(s):
--
Related Products: JeppView for Windows
PROBLEM:
After an update to Windows or JeppView, the program will not start and provides the following message:
This can occur to .dll files in the "JeppView for Windows" folder including, but not limited to, J3Chart.dll,J3Route.dll, J3Wx.dll.
CAUSE:
A JeppView .dll file in the C:\Program Files (x86)\Jeppesen\JeppView for Windows path was damaged, corrupted, or deleted during a Windows OS or JeppView update.
RESOLUTION:
Replace the .dll file (in this case J3Chart.dll) with the file provided from Jeppesen Support. Otherwise, uninstall and reinstall the program if the Jeppesen Program and Data disk is available.