Close
The Enhanced Jeppesen Digital Success Site is just around the corner! Stay tuned for updates (Learn more)
kA24W0000005Gs1SAE
"Unable to contact host server ..." when launching eLink for Windows
Created Date:
Jan 2025
Article ID:
000010615
Version:
1
Environment:
Windows
Document Type(s):
--

PROBLEM:
The following message appears when launching eLink for Windows:

"Unable to contact host server "[SERVER NAME]". Network may be down or the host server is not running."


User-added image


CAUSE:
eLink for Windows is configured to get database updates from a CDA Server and is unable to contact the host server the CDA service is running on. This may be due to the eLink for Windows computer not being connected to the same network as the CDA Server, or the CDA Server being offline.

When this occurs, the following messages will appear in the eLink for Windows log file:

[Tcp Client] 2022-04-14 12:35:47:811 11956 464 DEBUG: Connecting to [SERVER NAME]:139
[Tcp Client] 2022-04-14 12:35:54:951 11956 464 ERROR: gethostbyname([SERVER NAME]) failed, err=11001, msg=Host not found
[Tcp Client] 2022-04-14 12:35:54:967 11956 464 DEBUG: Connecting to [SERVER NAME]:445
[Tcp Client] 2022-04-14 12:35:57:279 11956 464 ERROR: gethostbyname([SERVER NAME]) failed, err=11001, msg=Host not found
[Jeppesen e-Link for Windows] 2022-04-14 12:35:57:295 11956 464 INFO: Unable to contact host server "[SERVER NAME]". Network may be down or the host server is not running.

[Tcp Client] 2022-04-16 10:49:53:680 11480 8380 DEBUG: Connecting to [SERVER NAME]:445
[Tcp Client] 2022-04-16 10:49:53:700 11480 8380 DEBUG: SetNonBlocking(1), s=1472
[Tcp Client] 2022-04-16 10:49:53:722 11480 8380 DEBUG: ConnectWithTimeout, connect() rc=-1, s=1472, err=10035, msg=Operation would block [Tcp Client] 2022-04-16 10:50:13:754 11480 8380 DEBUG: connect timed out, err=10060, msg=Connection timed out, rc=Connect timed out
[Tcp Client] 2022-04-16 10:50:13:776 11480 8380 ERROR: Failed to connect to [SERVER IP ADDRESS]:445, err=10060, msg=Connection timed out, rc=Connect timed out
[Tcp Client] 2022-04-16 10:50:13:776 11480 8380 DEBUG: shutdown(1472, SD_SEND), rc=-1
[Tcp Client] 2022-04-16 10:50:13:792 11480 8380 DEBUG: shutdown(1472, SD_SEND), err=183, msg=<system error>
[Tcp Client] 2022-04-16 10:50:13:823 11480 8380 DEBUG: closesocket(1472), rc=0
[Tcp Client] 2022-04-16 10:50:13:823 11480 8380 ERROR: Failed to connect to [SERVER NAME]:445
[Jeppesen e-Link for Windows] 2022-04-16 10:50:13:855 11480 8380 INFO: Unable to contact host server "[SERVER NAME]". Network may be down or the host server is not running.



RESOLUTION:
Verify you are connected to the same network as the CDA Server and that the CDA Server is online.

Test the connection to the CDA Server using Windows PowerShell (Type Powershell in the Windows search field) and the following commands. Replace [SERVER NAME] with the host server name that appears in the error message.

Test-NetConnection -ComputerName [SERVER NAME] -Port 139
Test-NetConnection -ComputerName [SERVER NAME] -Port 8812


Example of a successful connection test:
User-added image


Examples of unsuccessful connection tests:
User-added image

User-added image

comment
Contact Us