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"A valid TerminalCharts directory was not found..." when launching eLink for Windows
Created Date:
Jan 2025
Article ID:
000010684
Version:
2
Environment:
Windows
Document Type(s):
--
Related Products: eLink for Windows

PROBLEM:
The following error message appears when launching eLink for Windows:

"A valid TerminalCharts directory was not found. Would you like to browse for it?"


eLink_TCNotFound.JPG

The error may reoccur after clicking Yes, selecting the C:\ProgramData\Jeppesen\Common\TerminalCharts directory, and clicking OK:

eLink_TCNotFoundb.jpg

The following error will appear after clicking No:

Plug-in Initialization Errors
'TerminalData.dll' failed on provider initialization. Failed to initialize TC db [C:\ProgramData\Jeppesen\Common\TerminalCharts\] Improper or corrupt Terminal Chart data...


eLink_TCInitializationFailed.JPG

CAUSE:
A problem was encountered during an update to the terminal charts database, which prevented the Jeppesen Update application from extracting the new terminal charts database to C:\ProgramData\Jeppesen\Common\TerminalCharts. This can occur if eLink is launched while the Jeppesen Update is installing the new terminal charts database. Do not launch eLink while the Jeppesen Update is updating terminal charts and text.


eLink_TCNotFound_1.jpg


eLink_TCNotFound_3.jpg


eLink_TCNotFound_4.jpg

Possible error: The TermChart folder 'C:\ProgramData\Jeppesen\Common\TerminalCharts' contains no data!

eLink_TCNotFound_5.jpg

RESOLUTION:
Copy the contents of C:\ProgramData\Jeppesen\Common\TerminalChartsTemp to C:\ProgramData\Jeppesen\Common\TerminalCharts, selecting 'Replace the files in the destination' if prompted that the destination has files with the same names.

NOTE: The ProgramData folder may be hidden, in which case you can type C:\ProgramData in the location/address bar at the top of File Explorer and press the Enter key to open it, or click View > 'Hidden items'.


CommonTC_TCTemp_TC_1.jpg
CommonTC_TCTemp_TC_2.jpg

CommonTC_TCTemp_TC_3.jpg

If a TerminalChartsTemp directory does not exist, check the Date Modified on each of the TerminalCharts folders (TerminalCharts.0, TerminalCharts.alt), and copy the data from the one that was most recently updated to the primary TerminalCharts folder. Relaunch eLink.

CAUSE:
The registry key for the Terminal Charts path is pointed to a different folder than the one that received the charts update.

RESOLUTION:

Registry Disclaimer:
This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base: How to back up and restore the registry in Windows: http://support.microsoft.com/kb/322756


From the Start menu, search for and open regedit.exe. Open the following registry key:

HKEY_LOCAL_MACHINE > SOFTWARE > Wow6432Node > Jeppesen > Jeppesen e-Link for Windows > Paths > TerminalCharts

Set the Value Data for this key to "C:\ProgramData\Jeppesen\Common\TerminalCharts\" and then relaunch eLink.

TerminalChart Path


CAUSE:
Corruption with terminal chart data.

RESOLUTION:
Try reloading the most recent
Jeppesen Program and Data Disc .

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