PROBLEM:
The following errors are encountered when attempting to activate eLink for Windows, eCharts for Windows, or JeppView for Windows:
"Unable to connect: Error -1 (Invalid socket)"
"Site Key generation error -21."
CAUSE:
The Activation Wizard is unable to establish a connection to www.jepptech.com to complete the activation. This can occur if an Internet connection is not available, or if a firewall or network security application is blocking www.jepptech.com or the eLink, eCharts, or JeppView applications.
To verify if www.jepptech.com is blocked, open a browser and go to www.jepptech.com. Alternatively, launch Windows Powershell and run the following command:
Test-NetConnection -ComputerName www.jepptech.com -Port 80
Example of what will appear if www.jepptech.com is blocked:
Example of what will appear if www.jepptech.com is not blocked, but eLink.exe, eCharts.exe, or JeppView.exe are blocked:
Example of what will appear if www.jepptech.com and eLink.exe, eCharts.exe, or JeppView.exe are not blocked:
RESOLUTION:
Either connect the computer to the Internet, or select one of the alternative activation methods. If the computer is connected to the Internet, adjust the settings of the firewall or network security application to allow connections to www.jepptech.com. It may also be necessary to adjust the settings to allow connections from the eLink.exe, eCharts.exe, or JeppView.exe applications.