PROBLEM:
The following error is encountered when launching Jeppesen Distribution Manager (JDM) Windows:
Local Web Server Error: No IP port found!
CAUSE:
JDM is unable to read from or write to the directory C:\ProgramData\Jeppesen\Jdm\.jsum\cache
To verify if the current user is unable to write to the directory C:\ProgramData\Jeppesen\Jdm\.jsum\cache, browse to this directory in Windows Explorer, right-click inside the cache directory, then click New. If the current user has permission to write to the directory, there will be multiple options listed for creating folders and files within the directory, as shown below:
If the current user does not have write permission to the directory, only the Folder option will be listed after clicking New, as shown below:
RESOLUTION:
Obtain write permission to the C:\ProgramData\Jeppesen\Jdm\.jsum\cache directory or to the parent directories if the restriction is inherited from a parent directory.
CAUSE:
The Mongoose local web server component used by JDM is unable to run due to another process using the same TCP port, 8082. This can be identified by the following error showing up in the jsum.log file under C:\ProgramData\Jeppesen\Jdm\.jsum\log
ERROR - "Failed to start Mongoose"
RESOLUTION:
To see the processes that are running and which ports they are using, open the Windows Resource Monitor by typing Resource Monitor in Windows search bar. In Resource Monitor, select the Network tab, then expand Listening Ports at the bottom. Click on the Port column to sort the list by the port number. In the example below, the RNADiagnosticssrv.exe process is using TCP port 8082, the same TCP port that JDM is attempting to use.
Although JDM should attempt to use a different port if the default port 8082 is in use or blocked, it may be necessary to change the port that JDM uses. Right-click on the Jeppesen Distribution Manager desktop shortcut and select Properties. On the Shortcut tab, add the following to the end of the Target (you can try using 8083, 8084, or 8085):
-p 8083
For example:
"C:\Program Files (x86)\Jeppesen\Jdm\jdmclient.exe" -w "C:\ProgramData\Jeppesen\Jdm\.jsum" -c jdmx_win –p 8083