PROBLEM:
Database updates appear in JDM with "Status: No more updates available this cycle" and/or "Transfers Remaining: 0" even though the database update has not been downloaded or transferred yet.
CAUSE:
The Garmin Pilot app has been activated with the Jeppesen charts license for the service that indicates "no more updates available this cycle" and the Database Concierge feature is being used to transfer charts database updates to an avionics system associated to a different license/subscription.
RESOLUTION:
Go to Settings > Jeppesen within Garmin Pilot to determine which license is being used to provide the Jeppesen charts database to the Garmin Pilot app. If it's not apparent as to which avionics manufacturer/model the license is for, note the 16-character serial number that is displayed. Then, log into the JDM application, which displays the serial number, avionics manufacturer, model, and tail number.
To switch to a different license, tap Deactivate under Settings > Jeppesen in Garmin Pilot, then tap Activate a License to select a different license.