"Your account has been locked" when logging into my.jeppesen.com
Created Date:
Jan 2025
Article ID:
000010770
Version:
1
Environment:
Internet Browser
Document Type(s):
--
Related Products: --
PROBLEM:
The following message appears when logging into my.jeppesen.com:
"Your account has been locked. Please contact us for assistance."
CAUSE:
Attempting to log in with an incorrect password multiple times consecutively will lock the account for approximately 3-5 hours.
RESOLUTION:
Wait 3-5 hours for the account to unlock.