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"Database Not Digitally Signed", "Database Signature Verification Failed" when updating a Garmin GTN 600/700 Xi Series database
Created Date:
Feb 2025
Article ID:
000010776
Version:
5
Environment:
Avionics System/GPS
Document Type(s):
--
Related Products: --

PROBLEM:
When updating a database on a Garmin GTN 600/700 Xi Series Navigator, the following messages appear on the Database Updates page:

"Database Not Digitally Signed"

"Database Signature Verification Failed"


CAUSE:
Garmin GTN 600/700 Xi Series Navigators with software version 20.30 and higher require additional files used for improved data validation. The SD card is missing the required files either due to the account being set up with databases for an earlier-generation, non-Xi GTN 600/700 Series Navigator, or the System ID has not been applied to the GTN 600/700 Xi Series service in Jeppesen Distribution Manager.

Example of an earlier-generation, non-Xi GTN 600/700 Series database in Jeppesen Distribution Manager:


GTN750_JDM.jpg


Example of a GTN 600/700 Xi Series database in Jeppesen Distribution Manager:

GTN750Xi_JDM.jpg


Example of a GTN 600/700 Xi Series database without a System ID in Jeppesen Distribution Manager:

GTN750Xi_NoSystemID.jpg


Example of a GTN 600/700 Xi Series database with a System ID in Jeppesen Distribution Manager:

GTN750Xi_SystemID.jpg



RESOLUTION:
Contact Sales Support to have your account set up for databases for a Garmin GTN 600/700 Xi Series Navigator. Please have the system ID of your GTN 600/700 Xi Series Navigator available in order to link it to the databases on your account.

Refer to the following articles for additional guidance on locating the system ID, and applying the system ID to the databases in Jeppesen Distribution Manager:

How to find the System ID and Software Version of a Garmin avionics system using JDM and the SD card

How to find the software version and System ID of a Garmin device

Verifying and applying a Garmin System ID to a service in Jeppesen Distribution Manager

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