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Packages appear with status "Error: Failed to download" in the Content Delivery Agent for Desktop (CDAD)
Created Date:
Feb 2025
Article ID:
000001243
Version:
6
Environment:
Windows
Document Type(s):
--

ERROR:
Packages in the Content Delivery Agent for Desktop (CDAD) show a status of "Error: Failed to download".

CAUSE:
Incorrect DDM Server URL was entered when the CDAD was registered. For example, https://www.jeppesen.com/ddm/services/CDAService may have been entered instead of https://www.jeppesen.com:443/ddm .

RESOLUTION:
Verify the DDM Server URL on the Configure > Registration tab of the CDAD. If the URL is not https://www.jeppesen.com:443/ddm, correct it by unregistering the CDAD, correcting the DDM Server URL, then registering the CDAD. Note that before the CDAD can be re-registered, the associated recipient or review device must also be unregistered from within DDM.



CAUSE:
Anti-virus software is interfering with the download or unzipping of the package, or there is insufficient free space in the storage location specified under Configure > Storage and Connections.

The following errors; 'Cannot open destination file' and 'exception getting freeSpace...' may appear in the Message Log tab, or in the cda.log file:

2024‐01‐15 07:22:53,198:<ERROR> [InstructionProcessorThread] <common.model.DDMDeliverySystem> downloadPackage(JEP43‐ENRC‐0006): Error downloading package from https://www.jeppesen.com/ddm:Cannot open destination file
2024‐01‐15 07:22:53,198:<ERROR> [InstructionProcessorThread] <common.model.InstructionProcessor> Package JEP43‐ENRC‐0006:Failed to download null
2024‐01‐15 07:52:33,974:<ERROR> [StateChangeThread] <common.model.AgentModel> Exception getting freeSpace java.io.IOException: Command line did not return any info for command [cmd.exe, /C, dir /‐c E:] at org.apache.commons.io.FileSystemUtils.performCommand(FileSystemUtils.java:425) at org.apache.commons.io.FileSystemUtils.freeSpaceWindows(FileSystemUtils.java:225) at org.apache.commons.io.FileSystemUtils.freeSpaceOS(FileSystemUtils.java:194) at org.apache.commons.io.FileSystemUtils.freeSpaceKb(FileSystemUtils.java:166) at com.jeppesen.ebiz.ddm.delivery.common.model.AgentModel.getAvailableSpaceMB(AgentModel.java:958) at com.jeppesen.ebiz.ddm.delivery.common.model.DDMDeliverySystem.generateClientXml(DDM DeliverySystem.java:209) at com.jeppesen.ebiz.ddm.delivery.common.model.DDMDeliverySystem.synchronizeState(DDMDeliverySystem.java:56) at com.jeppesen.ebiz.ddm.delivery.common.model.AgentModel.synchronizeState(AgentModel.java:433) at com.jeppesen.ebiz.ddm.delivery.common.model.StateChangeWorkflow.synchronizeState(StateChangeWorkflow.java:75) at com.jeppesen.ebiz.ddm.delivery.common.model.StateChangeWorkflow.stateChangeWorkflow (StateChangeWorkflow.java:135) at com.jeppesen.ebiz.ddm.delivery.common.model.StateChangeWorkflow.stateChangeWorkflow Loop(StateChangeWorkflow.java:48) at com.jeppesen.ebiz.ddm.delivery.common.model.StateChangeThread.run(StateChangeThread.java:20)



RESOLUTION:
Ensure there is sufficient free space available in the location specified under Configure > Storage and Connections, and that the location is accessible. If possible, temporarily disable any anti-virus software or disable active scanning to see if the anti-virus software may be causing the problem.

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