PROBLEM:
The following error message appears when launching JeppView for Windows:
A valid TerminalCharts directory was not found. Would you like to browse for it?
The error may reoccur after clicking Yes, selecting the C:\ProgramData\Jeppesen\Common\TerminalCharts directory, and clicking OK:
The following error will appear after clicking No:
Plug-in Initialization Errors
'TerminalData.dll' failed on provider initialization. Failed to initialize TC db [C:\ProgramData\Jeppesen\Common\TerminalCharts\] Improper or corrupt Terminal Chart data...
CAUSE:
A problem was encountered during an update to the terminal charts database, which prevented the Jeppesen Update application from extracting the new terminal charts database to C:\ProgramData\Jeppesen\Common\TerminalCharts. The following message may appear at the end of the Jeppesen Update process:
The update completed with errors.
The TermChart folder 'C:\ProgramData\Jeppesen\Common\TerminalCharts' contains no data!'
This can occur if JeppView is launched while the Jeppesen Update is installing the new terminal charts database. Do not launch JeppView while the Jeppesen Update is updating terminal charts and text.
RESOLUTION:
Copy the contents of C:\ProgramData\Jeppesen\Common\TerminalChartsTemp to C:\ProgramData\Jeppesen\Common\TerminalCharts, selecting 'Replace the files in the destination' if prompted that the destination has files with the same names.
NOTE: The ProgramData folder may be hidden, in which case you can type C:\ProgramData in the location/address bar at the top of File Explorer and press the Enter key to open it, or click View > 'Hidden items'.
If a TerminalChartsTemp directory does not exist, check the Date Modified on each of the TerminalCharts folders (TerminalCharts.0, TerminalCharts.alt), and copy the data from the one that was most recently updated to the primary TerminalCharts folder. Relaunch JeppView.
CAUSE:
The registry key for the Terminal Charts path is pointed to a different folder than the one that received the charts update.
RESOLUTION:
Registry Disclaimer:
This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base: How to back up and restore the registry in Windows: http://support.microsoft.com/kb/322756
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From the Start menu, search for and open regedit.exe. Open the following registry key:
HKEY_LOCAL_MACHINE > SOFTWARE > Wow6432Node > Jeppesen > JeppView for Windows > Paths > TerminalCharts
Set the Value Data for this key to "C:\ProgramData\Jeppesen\Common\TerminalCharts\" and then relaunch JeppView.
CAUSE:
Corruption with terminal chart data.
RESOLUTION:
Try reloading the most recent Jeppesen Program and Data Disc .