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"Data server failed to initialize" and "Nav Data path file(s) could not be found" when opening eLink for Windows
Created Date:
Feb 2025
Article ID:
000001328
Version:
7
Environment:
Windows
Document Type(s):
--
Related Products: eLink for Windows

ERROR:
The following errors appear when opening eLink for Windows:

The Nav Data Path file(s) could not be found in:
"C:\ProgramData\Jeppesen\Common\C2E4\Data1\"
Would you like to locate the folder?

Data server failed to initialize.

Data Path Nav Data Path is missing, empty, or contains the wrong file(s).
Path = "C:\ProgramData\Jeppesen\Common\C2E4\Data1\"

If this is the first time Jeppesen e-Link for Windows
is being run please update data first
or check the installation



CAUSE:
The enroute data (J3N V4) is either missing or corrupt.

NOTE: If you receive the message "Unable to contact CDA" when opening eLink for Windows, please review the steps in the following knowledge article BEFORE continuing on:
"Unable to contact CDA" when starting eLink for Windows


RESOLUTION:

Navigate to
C:\ProgramData\Jeppesen\CDA\data_archive\j3n4_2 .

NOTE: The ProgramData folder may be hidden, in which case you can type C:\ProgramData in the location/address bar at the top of File Explorer and press the Enter key to open it, or click View > 'Hidden items' in Windows 10, or View > Show > 'Hidden items' in Windows 11.

If the j3n4_2 folder is present and contains files such as Airport.J3N, Airport_City.J3I, etc:

  1. Copy the contents of the C:\ProgramData\Jeppesen\CDA\data_archive\j3n4_2 folder into the C:\ProgramData\Jeppesen\CDA\data\j3n4 folder, replacing all files with the same names:




  2. Open eLink for Windows, at which point it should indicate that it's applying an update on the initialization screen.


If eLink for Windows doesn't indicate that it's applying an update and the error message continues to appear, follow the steps below:

Registry Disclaimer:
This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base: How to back up and restore the registry in Windows: http://support.microsoft.com/kb/

  1. Open the Windows Registry Editor by opening the Windows Start Menu and typing regedit in the Run or Search box, then pressing Enter. If a User Account Control message appears, select Yes to allow the Registry Editor to make changes to the computer.
  2. Navigate to either of the following locations depending on whether you have a 32-bit or 64-bit computer:
32-bit: HKEY_LOCAL_MACHINE\SOFTWARE\Jeppesen\Jeppesen e-Link for Windows\Data
64-bit: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Jeppesen\Jeppesen e-Link for Windows\Data
  1. Double-click on the UsingCDA value on the right window pane and make sure it has a Value Data of 1 . If it is set to 0, change it to 1 .
  2. Select OK, then close the Registry Editor.
  3. Open eLink for Windows at which point it should indicate that it is applying an update on the initialization screen.

If the C:\ProgramData\Jeppesen\CDA\data_archive\j3n4_2 folder is missing or empty:

A connection problem is preventing the CDA Service from downloading the enroute data. The most likely causes are the computer is not connected to the Internet, or a firewall is blocking the connection.

  1. Browse to C:\ProgramData\Jeppesen\CDA\log and open the CDA.log file.
  2. Scroll towards the end of the file for the most current entries.
  3. If "Couldn't connect to server" appears, followed by a url, this url is most likely being blocked by a firewall. The firewall could also be configured to block all communication from the Jeppesen CDA Service.

Refer to your firewall vendor's instructions for configuring the firewall to allow access to the Jeppesen CDA Service, as well as the addresses and ports listed next to 'Version 5.x Enroute Data Updates (CDA)' on theeLink for Windows Required Server Addresses support article.

If a proxy server is being used, the address and port may need to be entered on the Network tab of the CDA Service Monitor in order for the CDA to connect to the Internet. One way to determine if a proxy server is being used is to open Internet Explorer, then go to Internet Options > Connections > LAN Settings. If "Use automatic configuration script" or "Use a proxy server for your LAN" is checked, this indicates a proxy server is being used.

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