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Install or Update of Jeppesen Distribution Manager (JDM) for Mac is failing
Created Date:
Feb 2025
Article ID:
000001545
Version:
7
Environment:
Mac OS
Document Type(s):
--

PROBLEM:
When attempting to install Jeppesen Distribution Manager (JDM) for Mac, the installer is stalling or failing during the process, as shown in the following image:

TIP!
The macOS install.log can be helpful in diagnosing and fixing JDM for Mac installation problems. Refer to the following article for more information on the install.log file:
Access the MacOS install log to troubleshoot JDM for Mac installation problems



CAUSE:
The Mac does not meet the system requirements necessary to run the program. You can identify the version of macOS by clicking the Apple logo, then About This Mac.


RESOLUTION:
Ensure the computer meets the minimum requirements listed at the top of the Jeppesen Distribution Manager (JDM) Mac OS product support page.


CAUSE:
The current user is not an Administrator, or if the user is an Administrator, there may be a problem with the permissions.

RESOLUTION:
Create a new Administrator user, log into the Mac under the new Administrator user, and attempt to install JDM again.

https://support.apple.com/guide/mac-help/set-up-other-users-mtusr001/mac



CAUSE:
JDM was previously installed, but moved from /applications to another location. In this situation, the Install.log will show the following:

2024-09-12 11:53:28-06 Laptop-4 installd[806]: PackageKit: Applications/JdmApp.app relocated to Users/Jeff/Library/Mobile Documents/com~apple~CloudDocs/Desktop/JdmApp.app
...
...
2024-09-12 11:53:33-06 Laptop-4 package_script_service[962]: ./postinstall: /tmp/PKInstallSandbox.bctQxF/Scripts/com.jeppesen.jdmapp.TdWh5d/postinstall: line 71: cd: /Applications/JdmApp.app/Contents/Helpers: No such file or directory
...
...
2024-09-12 11:53:33-06 Laptop-4 installd[806]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “jdm_3.14.0.60_jdmx_x64 (3).pkg”." UserInfo={NSFilePath=./postinstall, NSURL=file:///Users/Jeff/Downloads/jdm_3.14.0.60_jdmx_x64%20(3).pkg#jdmapp.pkg, PKInstallPackageIdentifier=com.jeppesen.jdmapp, NSLocalizedDescription=An error occurred while running scripts from the package “jdm_3.14.0.60_jdmx_x64 (3).pkg”.} {
  NSFilePath = "./postinstall";
  NSLocalizedDescription = "An error occurred while running scripts from the package \U201cjdm_3.14.0.60_jdmx_x64 (3).pkg\U201d.";
  NSURL = "file:///Users/Jeff/Downloads/jdm_3.14.0.60_jdmx_x64%20(3).pkg#jdmapp.pkg";
  PKInstallPackageIdentifier = "com.jeppesen.jdmapp";
 }


During an update install, macOS will dutifully update (redirect to) the moved copy, but the installer still expects JDM to be in the /Applications folder, hence it can’t find the /Helpers directory because JDM is no longer installed in the /Applications folder.

You can see in the install.log file excerpt that the JDM app was “relocated”:


2024-09-12 11:53:28-06 Laptop-4 installd[806]: PackageKit: Applications/JdmApp.app relocated to Users/Jeff/Library/Mobile Documents/com~apple~CloudDocs/Desktop/JdmApp.app


Then here when the script tries to run it fails:


cd: /Applications/JdmApp.app/Contents/Helpers: No such file or directory



RESOLUTION:
The relocated JDM application will need to be deleted so that macOS will not relocate the update during the installation. In this example, removed Users/Jeff/Library/Mobile Documents/com~apple~CloudDocs/Desktop/JdmApp.app and successfully installed JDM.

Refer to Relocated Items in MacOS Catalina for more information.

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