“Failed to read from CDA network path:” when opening eLink for Windows or eCharts for Windows.
CAUSE:
The application is configured to get updates from a CDA server and does not have read access to the shared directory.
RESOLUTION:
Try entering the CDA network path displayed in the message into the search field under the Start menu in Windows, or enter it into the address field in File Explorer. If the client is able to access the shared directory, then it should come up.
Otherwise, an access denied or similar error will appear, or you may be prompted to enter your network credentials to access the network path.
In this case, please contact your company's IT department to make sure the shared directory is set up correctly and that you have the necessary permissions to access it.
CAUSE:
The CDA on the server is set to Local mode instead of Network mode. If the path in the error message is C:\ProgramData\Jeppesen\CDA\data\jds\echart\, this indicates the CDA on the server is not set to Network mode and does not have a shared data path set. This can also be verified by looking for the following error in the log file under C:\Users\Public\Public Documents\Jeppesen\Jeppesen e-Link for Windows\Logs or C:\Users\Public\Public Documents\Jeppesen\Jeppesen eCharts for Windows\Logs:
ERROR: Client cannot access path returned from network CDA [C:\ProgramData\Jeppesen\CDA\data\jds\echart\]
RESOLUTION:
In this case, open the CDA Service Monitor on the server. If the Mode on the Status tab is Local, it must be changed to Network. The CDA must first be stopped before going to File > Service Mode in order to change it to Network. After changing it to Network, the share path can be entered on the Settings tab.