The Jeppesen Distribution Manager (JDM) for Windows user interface does not load correctly; only a blank, white window appears
Created Date:
Jan 2025
Article ID:
000001784
Version:
7
Environment:
Windows
Document Type(s):
--
Related Products: Jeppesen Distribution Manager (JDM) Windows
PROBLEM:
The Jeppesen Distribution Manager (JDM) for Windows user interface does not load correctly; only a blank, white window appears.
Additionally, a pop-up window stating "You'll need a new app to open this data link" may appear ...
... and clicking Help > About may show the version as 4.0.1 instead of the correct version.
CAUSE:
A removable drive (e.g. SD card, USB drive) connected to the computer is being accessed by another process. For example, this issue may be encountered when deleting the contents of a removable drive at the same time JDM is launched.
RESOLUTION:
Close JDM, disconnect any removable drives (e.g. SD cards, USB drives), and try launching JDM again.
CAUSE:
The local web server component used by JDM is unable to run due to another process using the same TCP port, 8082. This can be identified by the following error showing up in the jsum.log file under C:\ProgramData\Jeppesen\Jdm\.jsum\log
ERROR - "Failed to start Mongoose"
RESOLUTION:
To see the processes that are running and which ports they are using, open the Windows Resource Monitor by typing Resource Monitor in Windows search bar. In Resource Monitor, select the Network tab, then expand Listening Ports at the bottom. Click on the Port column to sort the list by the port number. In the example below, the RNADiagnosticssrv.exe process is using TCP port 8082, the same TCP port that JDM is attempting to use.
Although JDM should attempt to use a different port if the default port 8082 is in use or blocked, it may be necessary to change the port that JDM uses. Right-click on the Jeppesen Distribution Manager desktop shortcut and select Properties. On the Shortcut tab, add the following to the end of the Target (you can try using 8083, 8084, or 8085):
-p 8083
For example:
"C:\Program Files (x86)\Jeppesen\Jdm\jdmclient.exe" -w "C:\ProgramData\Jeppesen\Jdm\.jsum" -c jdmx_win –p 8083
Click Apply, then OK and try launching JDM again.
CAUSE:
If a dash symbol appears at the top-left of the white window, the program is unable to read or write to the htdocs directory under C:\ProgramData\Jeppesen\Jdm\.jsum\. The htdocs directory is either missing, empty, or cannot be read from or written to.
RESOLUTION:
If the htdocs directory under C:\ProgramData\Jeppesen\Jdm\.jsum\ is missing or is empty, uninstall and reinstall JDM to fix the problem. If the htdocs directory is present and contains other folders/files (e.g. alerts, css, docs, etc.), the JDM application may not be able to read from or write to the directory. Ensure that you are logged in under a Windows account with sufficient privileges to read from and write to this directory.
NOTE: The ProgramData folder may be hidden, in which case you can type C:\ProgramData in the location/address bar at the top of File Explorer and press the Enter key to open it, or click View > 'Hidden items'.