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Skybound adapter or Garmin data card are not showing up under Devices in Jeppesen Distribution Manager (JDM) Mac OS
Created Date:
Apr 2025
Article ID:
000001904
Version:
1
Environment:
Mac OS
Document Type(s):
--

PROBLEM:
The Skybound adapter and/or Garmin data card is not showing up in the list of Devices in Jeppesen Distribution Manager (JDM) Mac OS.

CAUSE:
A Skybound G1 adapter is being connected to the computer. JDM for Mac only supports the blue, single-slot Skybound G2 adapter. The silver, 3-in-1 and 2-in-1 Skybound G1 adapters are not supported in the JDM Mac OS application.

User-added image

RESOLUTION:
Use one of the blue, single-slot Skybound G2 adapters.


CAUSE:
A card is not inserted into the Skybound G2 adapter, is not inserted in the correct orientation, or is defective. Additionally, the Skybound G2 adapter may be defective, such as having a bent pin.



RESOLUTION:

  • Make sure to insert the NavData card (orange, silver, green, blue, or VFR/white label), not the TAWS/Terrain, Flight Plan Data, or Dummy cards (white labels).



  • The Garmin card must be inserted so that the label on the card is facing in the same direction as the Jeppesen logo on the Skybound G2 adapter.



  • Remove the Skybound G2 adapter and Garmin data card and insert them again, making sure the Garmin data card is seated firmly into the adapter.

  • If the card is still not found in JDM, remove the card and inspect the pins inside the Skybound G2 adapter to see if any are bent or broken.




  • Restart the computer and log back into JDM to see if the card is found after a restart.

  • If it still is not found, try using another Skybound G2 adapter or Garmin data card if available.

  • Make sure the Skybound G2 adapter is connected to a USB port on the computer. Do not connect it to an unpowered USB hub, extension cable, or a port on a keyboard or other peripheral device. If using a desktop computer, plug it into a port on the back of the CPU as the ports on the front are typically passive (unpowered ports). If using a Macbook, plug the computer into a power source and do not connect the Skybound USB adapter to a docking station.

  • Disconnect any non-essential USB devices from the computer that may be using high amounts of power, except for the mouse and keyboard.

  • Connect the Skybound G2 adapter to a powered USB hub (one that has a DC IN port) if one is available.

  • Uninstall and reinstall the Jeppesen Distribution Manager (JDM) Mac OS application.

  • It is also worth noting that having a second G2 adapter or second data card can aid in determining if an older card or adapter is defective.

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