Close
The Enhanced Jeppesen Digital Success Site is just around the corner! Stay tuned for updates (Learn more)
kA260000000L4orCAC
"Skybound G2 - Card not found" in Jeppesen Distribution Manager (JDM)
Created Date:
Apr 2025
Article ID:
000002116
Version:
5
Environment:
--
Document Type(s):
--

PROBLEM:
The following message appears when attempting to program a Garmin data card in Jeppesen Distribution Manager (JDM) Windows or JDM macOS:

"Skybound G2 - Card not found"


Or the following message appears in Jeppesen Distribution Manager (JDM) Mobile:

Unable to write file to Wombat
Skybound USB Adapter needs Garmin card.



CAUSE:
A card isn't inserted into the Skybound G2 adapter, isn't inserted in the correct orientation, or is defective. Additionally, the Skybound G2 adapter may be defective, such as having a bent pin.

RESOLUTION:

  • The card must be inserted so that the label on the card is facing in the same direction as the Jeppesen logo on the Skybound G2 adapter.

User-added image

  • Make sure to insert the NavData card (orange IFRW label, silver IFRW label, green IFREP label, blue IFR label, or white VFR label), not the TAWS/Terrain, Flight Plan Data, or Dummy cards (white label).


  • Remove the Skybound G2 adapter and Garmin data card and insert them again, making sure the Garmin data card is seated firmly into the adapter.
  • If the card is still not found in JDM, remove the card and inspect the pins inside the Skybound G2 adapter to see if any are bent or broken, and inspect the card to see if any sockets are blocked by debris.

SkyBoundUSB_bentpin.png

GarminCard_blockedsocket.png

  • Reboot the computer with the Skybound G2 adapter and Garmin Data card plugged in, and then log back into JDM to see if the card is found after a reboot.
  • If it's still not found, try using another Skybound G2 adapter or Garmin data card if available.
  • Make sure the Skybound G2 adapter is connected to a USB port on the computer. Do not connect it to an unpowered USB hub, extension cable, or a port on a keyboard or other peripheral device. If using a desktop computer, plug it into a port on the back of the CPU as the ports on the front are typically passive (unpowered ports). If using a laptop or tablet, plug the computer into a power source and do not connect the Skybound USB adapter to a docking station.
  • Disconnect any non-essential USB devices from the computer that may be using high amounts of power, except for the mouse and keyboard. However, the USB receivers for some wireless mice/keyboards have been known to cause the Skybound G2 or Garmin card to not be found. If using such a mouse/keyboard, try disconnecting the USB receiver temporarily and use another mouse/keyboard to see if it is causing the problem, or try moving the USB receiver and Skybound USB adapter to different USB ports on the computer.

  • Connect the Skybound G2 adapter to a powered USB hub (one that has a DC IN port) if one is available.

  • Uninstall and reinstall the Jeppesen Distribution Manager (JDM) application.

  • It's also worth noting that having a second G2 adapter or second data card can aid in determining if an older card or adapter is defective.
comment
Contact Us